0

Оператор цикла Пока

Организует итеративные вычисления с неизвестным количеством повторений

Синтаксис

Оператор цикла Пока имеет следующий синтаксис:

Пока УсловиеПовторения Цикл
    //операторы
КонецЦикла;

А также альтернативный англоязычный синтаксис:

While LoopCondition Do
    //операторы
EndDo;

Описание

Оператор цикла Пока с предусловием используются для организации повторяющихся вычислений, когда количество повторений заранее неизвестно и определяется процессе выполнения цикла.

Оператор цикла начинается с ключевого слова Пока и заканчивается ключевым словом КонецЦикла, после которого обязательно следует разделитель операторов ; (точка с запятой) (см. подробнее главу «Знакомство с программными модулями»). После ключевого слова Цикл и до ключевого слова КонецЦикла размещается тело цикла.

Условие представляет собой логическое выражение, принимающее одно из значений: или логическую истину, или логическую ложь. Если условие выполняется (говорят, условие истинно), тогда управление передается операторам, расположенным после ключевого слова Цикл. Если условие не выполняется (говорят, условие ложно), управление передается на первый оператор после ключевого слова КонецЦикла.

Тело цикла выполняется пока условие истинно. С помощью специальных операторов Прервать и Продолжить, расположенных в теле цикла, можно управлять процессом итеративных вычислений. Например, при достижении оператора Прервать, вычисления будут прерваны, а управление передано первому оператору, следующему за ключевым словом КонецЦикла.

Пример использования

Пример кода с использованием оператора цикла Пока

//подсчитаем итоговую сумму
ИтоговаяСумма = 0;
Пока Запрос.Группировка(1) = 1 Цикл
    ИтоговаяСумма =   ИтоговаяСумма + Запрос.Сумма;
КонецЦикла;

Читайте также:

  1. Как выйти из цикла?

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *