0

Оператор условия Если

Оператор условного выполнения

Синтаксис

Условный оператор Если имеет следующий синтаксис:

Если ОсновноеУсловие Тогда
	//Выполняется оператор 1
[ИначеЕсли АльтернативноеУсловие Тогда]
	//Выполняется оператор 2
[Иначе]
	//Выполняется оператор 3
КонецЕсли;

А также альтернативный англоязычный синтаксис:

If MainCondition Then
	//Running operator 1
[ElseIf AlternativeCondition Then]
	//Running operator 2
[Else]
	//Running operator 3
EndIf;

Описание

Оператор Если позволяет задать проверку условия перед выполнением одного или нескольких операторов. Если условие выполняется, выполняются и операторы, следующие за ним.
Если условие не выполняется, операторы будут пропущены.

Оператор условия начинается с ключевого слова Если и заканчивается ключевым словом КонецЕсли, после которого обязательно следует разделитель операторов ; (точка с запятой) (см. подробнее главу «Знакомство с программными модулями«). После ключевого слова Если и до ключевого слова Тогда размещается проверяемое условие.

Оператор условия может иметь несколько альтернативных ветвей выполнения. В этом случае второе и последующие условия размещаются между ключевыми словами ИначеЕсли и Тогда.

Кроме того, в условном операторе можно задать операторы, выполняемые по-умолчанию, когда не сработало ни одно из ранее определенных условий. Это делается после ключевого слова Иначе

Условие представляет собой логическое выражение, принимающее одно из значений: или логическую истину, или логическую ложь. Если условие выполняется (говорят, условие истинно), тогда управление передается операторам, расположенным после ключевого слова Тогда. Если условие не выполняется (говорят, условие ложно), управление передается на следующее альтернативное условие. Если альтернативное условие не определено, управление передается на операторы по умолчанию. Если и они не определены, управление передается на первый оператор после ключевого слова КонецЕсли

Пример использования

Пример кода с использованием оператора Если

Если Спр.ЭтоГруппа() = 1 Тогда
	Спр.Наименование = «Новая группа»;
Иначе
	Спр.Наименование = «Новый элемент»;
КонецЕсли;

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *