0

Оператор Продолжить

Оператор вызывает немедленный переход к проверке условия цикла

Синтаксис

Оператор Продолжить имеет следующий синтаксис:

Продолжить;

А также альтернативный англоязычный синтаксис:

Continue;

Описание

Оператор Продолжить используется в теле цикла для немедленного перехода в начало цикла для проверки условия.
При попытке использования оператора вне тела цикла, ограниченного ключевыми словами Цикл и КонецЦикла, синтаксический анализатор выдаст ошибку: «Оператор Continue (Продолжить) может употребляться только внутри цикла».

Пример использования

Пример кода с использованием оператора Продолжить

ИтоговаяСумма = 0;
Пока Запрос.Группировка(1) = 1 Цикл
    Если  Запрос.Сумма = 0 Тогда
        Продолжить;
    КонецЕсли;
    ИтоговаяСумма = ИтоговаяСумма + Запрос.Сумма;
КонецЦикла;

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *