0

Процедура ОбработкаОжидания()

Инициирует периодический вызов процедуры глобального модуля.

Синтаксис

Процедура ОбработкаОжидания() имеет следующий синтаксис:

строка ОбработкаОжидания([ИмяПроцедуры], [ИнтервалВызова])

А также альтернативный англоязычный синтаксис:

string IdleProcessing([ProcName], [Interval])

Параметры

Процедура ОбработкаОжидания() имеет следующие формальные параметры:

Имя Тип Описание
ИмяПроцедуры Строка Имя процедуры глобального модуля, которая должна вызываться с интервалом ИнтервалВызова.
Если передается пустая строка, то ранее подключенный обработчик ожидания отключается.
Если имя процедуры опущено, метод возвращает имя ранее подключенной процедуры.
ИнтервалВызова Число Периодичность запуска в секундах. Если передается 0, то ранее подключенный обработчик отключается

Возвращаемое значение

Строка
Имя подключенной процедуры (на момент до вызова метода)

Описание

Процедура ОбработкаОжидания() подключает периодический вызов процедуры глобального модуля с указанным интервалом времени.

Внимание! Может быть подключен только один обработчик ожидания. Поэтому, если необходимо отслеживать несколько параметров, их необходимо описать в одной процедуре глобального модуля

Пример использования

Пример кода с использованием процедуры ОбработкаОжидания():

//фрагмент глобального модуля:
Процедура ПриНачалеРаботыСистемы()
    
    //подключаем обработчик
    ОбработкаОжидания("Тест1", 3); 
    //переназначаем обработчик
    ОбработкаОжидания("Тест2", 3);
    
КонецПроцедуры

Процедура ПриЗавершенииРаботыСистемы()
      
    //отключаем обработчик, каким бы он ни был
    ОбработкаОжидания("");
    
КонецПроцедуры

Процедура Тест1()
    
    Сообщить("Тест1: " + ТекущееВремя());

КонецПроцедуры

Процедура Тест2()
    
    Сообщить("Тест2: " + ТекущееВремя());

КонецПроцедуры

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *