0

Оператор Прервать

Оператор вызывает немедленное прерывание цикла

Синтаксис

Оператор Прервать имеет следующий синтаксис:

Прервать;

А также альтернативный англоязычный синтаксис:

Break;

Описание

Оператор Прервать используется в теле цикла для немедленного прекращения работы цикла и передачи управления первому оператору, расположенному за ключевым словом КонецЦикла.
При попытке использовать оператор за пределами тела цикла, ограниченного ключевыми словами Цикл и КонецЦикла, синтаксический анализатор выдаст ошибку: «Оператор Break (Прервать) может употребляться только внутри цикла».

Пример использования

Пример кода с использованием оператора Прервать

ТекущаяСтрока = 0;
Для НомерСтроки = 1 По ТаблицаЗначений.КоличествоСтрок() Цикл
    ТекущаяСтрока = ТаблицаЗначений.ПолучитьСтрокуПоНомеру(НомерСтроки);
    Если (ТекущаяСтрока.ЗначениеА = "А") И (ТекущаяСтрока.ЗначениеБ = "Б") Тогда
        Прервать;//нашли нужную строку
    КонецЕсли;
КонецЦикла;

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *