0

Оператор цикла Для

Организует итеративные вычисления с известным количеством повторений

Синтаксис

Оператор цикла Для имеет следующий синтаксис:

Для Счетчик = НачЗначение По КонЗначение Цикл
    //операторы
КонецЦикла;

А также альтернативный англоязычный синтаксис:

For Counter = FromValue To ToValue Do
//операторы
EndDo;

Описание

Оператор цикла Для с параметром используются для организации повторяющихся вычислений с заранее известным количеством повторений.

Оператор цикла начинается с ключевого слова Для и заканчивается ключевым словом КонецЦикла, после которого обязательно следует разделитель операторов ; (точка с запятой) (см. подробнее главу «Знакомство с программными модулями»). После ключевого слова Цикл и до ключевого слова КонецЦикла размещается тело цикла.

В параметрах цикла задается начальное значение счетчика и его конечное значение. Шаг счетчика по умолчанию равен 1 (единице). Цикл будет выполняться до тех пор, пока текущее значение счетчика меньше конечного значения. Как только эти значения сравняются, цикл завершится, а управление перейдет на следующий за ключевым словом КонецЦикла оператор.

С помощью специальных операторов Прервать и Продолжить, расположенных в теле цикла, можно управлять процессом итеративных вычислений. Например, при достижении оператора Продолжить, управление будет снова передано в начало цикла для проверки условия.

Пример использования

Пример кода с использованием оператора цикла Для

//подсчитаем итоговую сумму
ИтоговаяСумма = 0;
Для Инд = 1 По ТаблицаЗначений.КоличествоСтрок() Цикл
    СтрокаТаблицы = ТаблицаЗначений.ПолучитьСТрокуПоНомеру(Инд);
    ИтоговаяСумма = ИтоговаяСумма +  СтрокаТаблицы.Сумма;
КонецЦикла;

Читайте также:

  1. Как выйти из цикла?

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *