0

Оператор Функция

Описывает функцию для повторного использования

Синтаксис

Описание функции во встроенном языке 1С:Предприятие 7.7 имеет следующий синтаксис:

Функция ИмяФункции([[Знач]Параметр1[ = ЗначениеПоУмолчанию],...,[Знач]ПараметрN[ = ЗначениеПоУмолчанию]])[Экспорт][Далее]
    //блок описания локальных переменных функции
    //блок операторов функции
    [Возврат Значение;]
КонецФункции

А также альтернативный англоязычный синтаксис:

Function FinctionName([[Val]Attr1[ = DefaultValue],...,[Val]AttrN[ = DefaultValue]])[Export][Forward]
    //local variables definition
    //function operators
    [Return Value;]
EndFunction

Описание

Конструкция Функция...КонецФункции позволяет разработчику определить собственный исполняемый оператор, возвращающий результат вычисления в точку вызова. Определение функции начинается с ключевого слова Функция и заканчивается ключевым словом КонецФункции. За ключевым словом Функция обязательно следует идентификатор функции и блок определения формальных параметров. Описывать параметры функции вовсе не обязательно. Обязательно лишь указать обязательный атрибут функции — круглые скобки.

Ключевое слово Экспорт используется в глобальном модуле для расширения области видимости функции. Функция, определенная как экспортная, будет доступна в любом другом программном модуле конфигурации.

Ключевое слово Далее используется при предварительном объявлении функции, чтобы сказать синтаксическому анализатору, что полное определение функции располагается ниже по тексту модуля.

Сразу за блоком формальных параметров и до ключевого слова КонецФункции располагается тело функции — объявления локальных переменных функции и последовательность исполняемых операторов. Переменные можно объявлять до первого исполняемого оператора. В случае нарушения этого требования, синтаксический анализатор выдаст ошибку: «Объявления переменных должны быть расположены в начале модуля, процедуры или функции».

В качестве операторов в теле функции можно использовать системные процедуры и функции, а также другие вспомогательные процедуры и функции, определенные программистом в конфигурации.

Также в теле функции можно использовать оператор Возврат, который прекращает выполнение функции и возвращает произвольное значение в точку вызова функции.

Обратите внимание, что после ключевого слова КонецФункции нет разделителя операторов ; (точка с запятой). Так вышло потому, что конструкция Функция...КонецФункции является по своей природе операторными скобками, а не оператором. Нарушение этого требования может привести к синтаксической ошибке: «Определения процедур и функций должны размещаться перед операторами основной программы».

Читайте также:

  1. Исполняемые операторы встроенного языка
  2. Оператор Возврат

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *