0

Оператор Возврат

Оператор прерывает выполнение процедуры или функции и возвращает управление в точку вызова.

Оператор Возврат можно указать в любом месте тела процедуры или функции. Попытка использования оператора вне тела процедуры или функции приведет к синтаксической ошибке: «Оператор Return (Возврат) не может употребляться вне процедуры или функции!»

Синтаксис

Для процедур:

Возврат;

Для функций:

Возврат Значение;

Обратите внимание, что для функций оператор Возврат обязательно должен иметь возвращаемое значение для передачи в точку вызова функции.

Пример использования

Пример использования оператора Возврат в теле процедуры:

Процедура Тест(Параметр = 0, ОписаниеОшибки = "")
	...
	Если Параметр = 0 Тогда
		ОписаниеОшибки  = "Передан пустой параметр!";
		Возврат;
	КонецЕсли;
	...
КонецПроцедуры

Пример использования оператора Возврат в теле функции:

Функция Тест(Параметр = 0)
	...
	Если Параметр = 0 Тогда
		Возврат "Передан пустой параметр!";
	КонецЕсли;
	...
КонецФункции

Читайте также:

  1. Оператор Процедура
  2. Оператор Функция

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *