0

Справочник
Метод ПометкаУдаления()

Возвращает признак пометки на удаление элемента справочника

Синтаксис

Метод ПометкаУдаления() имеет следующий синтаксис:

число ПометкаУдаления()

А также альтернативный англоязычный синтаксис:

number DeleteMark()

Параметры

Метод ПометкаУдаления() не имеет формальных параметров.

Возвращаемое значение

Число

1 — элемент помечен на удаление
0 — элемент не помечен на удаление

Описание

Метод ПометкаУдаления() возвращает признак пометки на удаление элемента справочника.

Внимание! Метод может использоваться только для объектов, созданных методом СоздатьОбъект()!

Пример использования

Пример кода с использованием метода ПометкаУдаления():

//очистка справочника от помеченных на удаление
//элементов, на который нет ссылок!!!	
Выборка = СоздатьОбъект("Справочник.Товары");
Если Выборка.ВыбратьЭлементы() = 1 Тогда
	Пока Выборка.ПолучитьЭлемент() = 1 Цикл
		Если Выборка.ПометкаУдаления() = 1 Тогда
			//удалим непосредственно!
			Выборка.Удалить(1);
		КонецЕсли;
	КонецЦикла;
КонецЕсли;

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *