0

Справочник
Метод СнятьПометкуУдаления()

Снимает пометку удаления с элемента справочника

Синтаксис

Метод СнятьПометкуУдаления() имеет следующий синтаксис:

СнятьПометкуУдаления()

А также альтернативный англоязычный синтаксис:

ClearDeleteMark()

Параметры

Метод СнятьПометкуУдаления() не имеет формальных параметров.

Описание

Метод СнятьПометкуУдаления() снимает пометку удаления с элемента справочника.

Внимание! Метод может использоваться только для объектов, созданных методом СоздатьОбъект()!

Пример использования

Пример кода с использованием метода СнятьПометкуУдаления():

//восстановление помеченных на удаление элементов справочника
Выборка = СоздатьОбъект("Справочник.Товары");
Если Выборка.ВыбратьЭлементы() = 1 Тогда
	Пока Выборка.ПолучитьЭлемент() = 1 Цикл
		Если Выборка.ПометкаУдаления() = 1 Тогда
			//удалим непосредственно!
			Выборка.СнятьПометкуУдаления();
		КонецЕсли;
	КонецЦикла;
КонецЕсли;

Читайте также:

  1. Метод Справочник.Удалить()

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *