0

Метод ОтметитьЗначения()

Метод предлагает пользователю выполнить интерактивный выбор нескольких значений в списке

Синтаксис

Метод ОтметитьЗначения() имеет следующий синтаксис:

число ОтметитьЗначения(Значение, [Заголовок], [Позиция], [Таймаут])

А также альтернативный англоязычный синтаксис:

number CheckValues(Value, [Title], [Position], [Timeout])

Параметры

Описание параметров метода ОтметитьЗначения()

Имя параметра Тип Описание
Значение* Произвольный Имя ранее объявленной переменной, куда будет помещен результат последнего выбора
Заголовок Строка Заголовок диалогового окна
Позиция Число Имя ранее объявленной переменной, куда будет помещена позиция последнего выбранного значения
Таймаут Число Время ожидания реакции пользователя в секундах. По истечении указанного времени диалог ввода автоматически закрывается. Если значение равно 0 (нулю) или не указано, время ожидания не ограничено. Значение по умолчанию: 0
* — обязательный параметр

Возвращаемое значение

Число

Описание вариантов возвращаемых значений:

1 — выбор выполнен (нажата кнопка «ОК»)
0 — выбор не выполнен (окно закрыто крестиком или кнопкой «Отмена»)
-1 — наступил таймаут (истекло время ожидания)

Описание

Метод ОтметитьЗначения() предлагает пользователю выполнить интерактивный выбор нескольких значений из заранее подготовленного списка значений. Значение, содержащееся в параметре Значение будет выделено в списке выбора как текущее. В этот же параметр помещается последнее отмеченное значение. Диалог для отметки значений выглядит следующим образом:

Диалоговое окно отметки значений в спискеПри дальнейшей обработке значений списка признак пометки можно получить с помощью метода Пометка()

Внимание!
Метод ОтметитьЗначения() используется только для списка значений, созданного функцией СоздатьОбъект().
Внимание!
Поскольку метод ОтметитьЗначения() открывает диалог ввода в модальном режиме, избегайте ее использования в модуле проведения документов, а также в пределах открытой транзакции в многопользовательском режиме работы 1С:Предприятие 7.7

Пример использования

Пример кода с использованием метода ОтметитьЗначения()

Перем ПериодДоставки, Представление;
 
//инициируем список выбора
сз = СоздатьОбъект("СписокЗначений");
сз.ДобавитьЗначение(9, "С 9:00 до 12:00");
сз.ДобавитьЗначение(12, "С 12:00 до 15:00");
сз.ДобавитьЗначение(15, "С 15:00 до 18:00");
сз.ДобавитьЗначение(18, "С 18:00 до 21:00");

//по умолчанию доставка днем
ПериодДоставки = 12;

Если сз.ОтметитьЗначения(ПериодДоставки, "Укажите желаемое время доставки") = 1 Тогда
    Для Инд = 1 По сз.РазмерСписка() Цикл
        Если сз.Пометка(Инд) = 1 Тогда
            сз.ПолучитьЗначение(Инд, Представление);
            Сообщить("Период доставки: " + Представление);
        КонецЕсли;
    КонецЦикла;
КонецЕсли;

Читайте также:

Объект СписокЗначений

Метод СписокЗначений.Пометка()

Метод СписокЗначений.ВыбратьЗначение()

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *