0

Метод Пометка()

Метод устанавливает\возвращает пометку элемента списка значений

Синтаксис

Метод Пометка() имеет следующий синтаксис:

число Пометка(Позиция [, Значение])

А также альтернативный англоязычный синтаксис:

number Check(Position [, Value])

Параметры

Описание параметров метода Пометка()

Имя параметра Тип Описание
Позиция* Число Позиция элемента списка. Должна быть в пределах от 1 до РазмерСписка()
Значение Число Новое значение пометки

Варианты значений
1 Установить пометку
0 Сбросить пометку
* — обязательный параметр

Возвращаемое значение

Число

Описание вариантов возвращаемых значений:

1 — пометка установлена
0 — пометка НЕ установлена

Описание

Метод Пометка() возвращает пометку элемента списка значений в указанной позиции. Через параметр Значение можно задать новое значение пометки.

Пример использования

Пример кода с использованием метода Пометка()

Перем ПериодДоставки, Представление;

//инициируем список выбора
сз = СоздатьОбъект("СписокЗначений");
сз.ДобавитьЗначение(9, "С 9:00 до 12:00");
сз.ДобавитьЗначение(12, "С 12:00 до 15:00");
сз.ДобавитьЗначение(15, "С 15:00 до 18:00");
сз.ДобавитьЗначение(18, "С 18:00 до 21:00");

//по умолчанию доставка днем
ПериодДоставки = 12;

Если сз.ОтметитьЗначения(ПериодДоставки, "Укажите желаемое время доставки") = 1 Тогда
    Для Инд = 1 По сз.РазмерСписка() Цикл
        Если сз.Пометка(Инд) = 1 Тогда
            сз.ПолучитьЗначение(Инд, Представление);
            Сообщить("Период доставки: " + Представление);
        КонецЕсли;
    КонецЦикла;
КонецЕсли;

Читайте также:

Метод СписокЗначений.ОтметитьЗначения()

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *