0

Функция ОписаниеОшибки()

Функция возвращает описание ошибки

Синтаксис

Функция ОписаниеОшибки() имеет следующий синтаксис:

строка ОписаниеОшибки()

А также альтернативный англоязычный синтаксис:

string GetErrorDescription()

Возвращаемое значение

Строка

Описание

Функция ОписаниеОшибки() возвращает текстовое описание ошибки, которая привела к возникновению исключительной ситуации в процессе выполнения операторов встроенного языка в конструкции Попытка … Исключение.
Функцию имеет смысл использовать только внутри блока Исключение … КонецПопытки. В остальных случаях она возвращает пустую строку.

Пример использования

Пример кода с использованием функции ОписаниеОшибки()

//расчет минимальной цены по таблице значений
МинЦена = 999999999; 

ТекущаяСтрока = 0;

Для НомерСтроки = 1 По ТаблицаЗначений.КоличествоСтрок() Цикл
    ТекущаяСтрока = ТаблицаЗначений.ПолучитьСтрокуПоНомеру(НомерСтроки);
    Если ТекущаяСтрока.Сумма > 0 Тогда
        Попытка
            МинЦена = Мин(МинЦена, ТекущаяСтрока.Сумма / ТекущаяСтрока.Количество);
        Исключение
            Сообщить("Строка[" + НомерСтроки + "]: " + ОписаниеОшибки(), "!!!");
        КонецПопытки;
    КонецЕсли;
КонецЦикла;      
   
Если МинЦена = 999999999 Тогда                
    Предупреждение("Не удалось определить минимальную цену!", 5);
Иначе
    Предупреждение("Минимальная цена = " + МинЦена, 5);
КонецЕсли;

Читайте также:

  1. Обработка исключительных ситуаций в конструкции Попытка .. Исключение

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *