0

Процедура ПриНачалеРаботыСистемы

Процедура выполняется при начале работы пользователя с системой.

Синтаксис

Процедура ПриНачалеРаботыСистемы() имеет следующий синтаксис:

Процедура ПриНачалеРаботыСистемы()
    ...
КонецПроцедуры

А также альтернативный англоязычный синтаксис:

Procedure OnStartSystem()
    ...
EndProcedure

Описание

Предопределенная процедура ПриНачалеРаботыСистемы() выполняется при начале интерактивной работы пользователя с системой.

По-умолчанию, система не выполняет каких-либо проверок. В результате, открывается окно приложения и пользователь может приступить к работе. Если при старте системы требуется проверить дополнительные условия (например, полномочия пользователя) или выполнить дополнительные настройки (например, создать временные файлы), необходимо разместить определение данной процедуры в глобальном модуле, а в теле процедуры описать требуемый алгоритм поведения системы.

Если по каким-либо причинам начало работы с системой запрещено, достаточно установить в теле процедуры статус возврата равным нулю и запуск приложения будет отменен.

Пример использования

Пример кода с использованием функции ПриНачалеРаботыСистемы()

Процедура ПриНачалеРаботыСистемы()
	
        СпрПользователи = СоздатьОбъект("Справочник.Пользователи");
        ПользовательОпределен = СпрПользователи.НайтиПоКоду(ИмяПользователя());
	Если ПользовательОпределен = 0 Тогда
            СтатусВозврата(0);
            Возврат;
	КонецЕсли;
	
КонецПроцедуры//ПриНачалеРаботыСистемы()

Читайте также:

  1. Предопределенная процедура ПриЗавершенииРаботыСистемы()

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *