0

Функция ОсновнойЯзык()

Функция определяет основной язык конфигурации

Синтаксис

Функция ОсновнойЯзык() имеет следующий синтаксис:

число ОсновнойЯзык()

А также альтернативный англоязычный синтаксис:

number GeneralLanguage()

Параметры

У функции ОсновнойЯзык() нет формальных параметров.

Возвращаемое значение

Число

Описание вариантов возвращаемых значений:

1 — основной язык конфигурации — русский
0 — основной язык конфигурации — английский

Описание

Функция ОсновнойЯзык() возвращает числовой код основного языка прикладной задачи, выбранный в свойствах конфигурации.
Знать, какой язык используется в конфигурации, бывает полезно для локализации сообщений, выводимых пользователю.

Пример использования

Пример кода с использованием функции ОсновнойЯзык()

Процедура ПриЗаписиИстории(ТипОбъекта)

    Перем Отказ;

    Если (ОсновнойЯзык() = 1) И (ТипОбъекта = "Константа.Версия") Тогда
        Сообщить("У Вас нет полномочий для завершения операции!", "!");
        Отказ = 1;
    ИначеЕсли (ОсновнойЯзык() = 0) И (ТипОбъекта = "Const.Версия") Тогда
        Сообщить("You don't have enough permissions for operation complete!", "!");
        Отказ = 1;
    КонецЕсли;
    
    Если Отказ = 1 Тогда
        СтатусВозврата(0);
    КонецЕсли;
    
КонецПроцедуры

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *