0

Как проверить переменную на пустое значение?

Как вы уже знаете, во встроенном языке 1С:Предприятие 7.7 тип переменной определяется типом хранимого значения. Довольно часто разработчику при описании алгоритма обработки данных требуется узнать,  содержит ли переменная или реквизит значение, или нет. Давайте разберемся, с помощью каких функций это можно сделать.

Если тип переменной известен

Если тип известен, можно сравнить значение переменной с пустым значением конкретного типа. Для типа «Число» это 0, для типа «Строка» — пустая строка, для типа «Дата» — литерал ‘  .  .  ‘. Чтобы получить пустое значение для прочих типов данных, можно воспользоваться функцией ПолучитьПустоеЗначение():

Если Сумма = 0 Тогда
	Сообщить("Не заполнена сумма!");
КонецЕсли;
...
Если Комментарий = "" Тогда
	Сообщить("Не заполнен комментарий операции!");
КонецЕсли;
...
Если Номенклатура = ПолучитьПустоеЗначение("Справочник.Номенклатура") Тогда
	Сообщить("Не заполнена номенклатура!");
КонецЕсли;

Если тип переменной не известен

Если тип не известен, можно просто проверить ее на пустое значение функцией ПустоеЗначение(), которая вернет 1 в случае, если переменная не содержит никакого значения:

Если ПустоеЗначение(Сумма) = 1 Тогда
	Сообщить("Не заполнена сумма!");
КонецЕсли;
...
Если ПустоеЗначение(Комментарий) = 1 Тогда
	Сообщить("Не заполнен комментарий операции!");
КонецЕсли;
...
Если ПустоеЗначение(Номенклатура) = 1 Тогда
	Сообщить("Не заполнена номенклатура!");
КонецЕсли;

Читайте также

  1. Полный список типов данных
  2. Как определить тип значения переменной?

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *