0

Функция Найти()

Возвращает первое вхождение подстроки в исходную строку

Синтаксис

Функция Найти() имеет следующий синтаксис:

Число Найти(ИсходнаяСтрока, ПодстрокаПоиска)

А также альтернативный англоязычный синтаксис:

number Find(SourceString, Substring)

Параметры

Описание параметров функции Найти():

Имя параметра Тип Описание
ИсходнаяСтрока Строка Исходная строка.
ПодстрокаПоиска Строка Искомая подстрока.
Жирным шрифтом выделены обязательные параметры

Возвращаемое значение

Число
Позиция первого знака найденной подстроки.

Описание

Функция Найти() находит первое вхождение искомой подстроки в исходной строке и возвращает номер позиции. Нумерация символов в строке начинается с 1. Если строка не содержит указанной подстроки, то возвращается 0. Если параметр ПодстрокаПоиска — пустая строка, то возвращает 1. Если оба обязательных параметра — пустые строки, то возвращает 1.

Внимание! Сравнение выполняется с учетом регистра (см. пример)
Внимание!! Функция является устаревшей! Рекомендуется использовать функцию СтрНайти()

Доступность

Тонкий клиент, веб-клиент, мобильный клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).

Пример использования

Пример кода с использованием функции Найти():

ИсходнаяСтрока = "abc";
Если Найти(ИсходнаяСтрока, "ab") > 0 Тогда
	Сообщить("Нашли ab");
КонецЕсли;
//обращайте внимание на регистр!
//следующая строка не будет найдена:
Если Найти(ИсходнаяСтрока, "Ab") = 0 Тогда
	Сообщить("Не нашли Ab");
КонецЕсли;
//чтобы найти, необходимо привести строку к одному регистру
Если Найти(Нрег(ИсходнаяСтрока), Нрег("Ab")) > 0 Тогда
	Сообщить("Нашли Ab");
КонецЕсли;

Читайте также:

  1. Новые строковые функции 1С 8.3
  2. Функция СтрНайти()

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *