0

СтрокаТаблицыЗначений
Метод Владелец()

Возвращает владельца текущей строки таблицы значений

Синтаксис

Метод Владелец() имеет следующий синтаксис:

ТаблицаЗначений Владелец()

А также альтернативный англоязычный синтаксис:

ValueTable Owner()

Параметры

Метод Владелец() не имеет формальных параметров.

Возвращаемое значение

ТаблицаЗначений

Описание

Метод Владелец() возвращает таблицу значений, в которой находится данная строка. Такая возможность делает строку самодостаточной, чтобы использовать ее в различных контекстах (см. пример).

Доступность

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).

Пример использования

Пример кода с использованием метода Владелец():

Функция УдалитьПустуюСтроку(СтрокаТЗ, ИмяКолонки = "")
   
   Перем тз;
   //а есть ли строка!?
   Если СтрокаТЗ = Неопределено Тогда
      Возврат Ложь;
   КонецЕсли;
   
   тз = СтрокаТЗ.Владелец();
   
   Если НЕ ПустаяСтрока(ИмяКолонки) Тогда
      //необходима проверка заполнения
      НайдКолонка = тз.Колонки.Найти(ИмяКолонки);
      Если НЕ НайдКолонка = Неопределено Тогда
         //проверка заполнения
         Если ЗначениеЗаполнено(СтрокаТЗ[ИмяКолонки]) Тогда
            Возврат Ложь;
         КонецЕсли;
      КонецЕсли;
   КонецЕсли;
   
   //удаляем строку
   тз.Удалить(СтрокаТЗ);    
   
   Возврат Истина;
   
КонецФункции //УдалитьПустуюСтроку()

Читайте также:

Программная работа с таблицей значений

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *