0

Функция СтрЧислоВхождений()

Возвращает число вхождений подстроки поиска в исходную строку.

Синтаксис

Функция СтрЧислоВхождений() имеет следующий синтаксис:

Число СтрЧислоВхождений(ИсходнаяСтрока, ПодстрокаПоиска)

А также альтернативный англоязычный синтаксис:

number StrOccurrenceCount(SourceString, Substring)

Параметры

Описание параметров функции СтрЧислоВхождений():

Имя параметра Тип Описание
ИсходнаяСтрока Строка Исходная строка.
ПодстрокаПоиска Строка Искомая подстрока.
Жирным шрифтом выделены обязательные параметры

Возвращаемое значение

Число
Число вхождений.

Описание

Функция СтрЧислоВхождений() вычисляет число вхождений подстроки поиска в исходной строке.

Внимание! Поиск выполняется с учетом регистра, аналогично функции СтрНайти()

Доступность

Тонкий клиент, веб-клиент, мобильный клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).

Пример использования

Пример кода с использованием функции СтрЧислоВхождений():

ИсходнаяСтрока = "123434";
Если СтрЧислоВхождений(ИсходнаяСтрока, "4") > 1 Тогда
	Сообщить("Должен быть только один символ");	
КонецЕсли;
//Внимание, поиск регистрозависимый!
ИсходнаяСтрока = "абвгд";
Если СтрЧислоВхождений(ИсходнаяСтрока, "А") = 0 Тогда
	Сообщить("Символа А нет");	
КонецЕсли;
//приводите исходную строку и строку поиска к одному регистру
ИсходнаяСтрока = "абвгд";
Если СтрЧислоВхождений(ИсходнаяСтрока, нрег("А")) > 0 Тогда
	Сообщить("Символ А найден");	
КонецЕсли;

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *