0

Процедура ОтключитьОбработчикОжидания()

Отключает указанный обработчик ожидания

Синтаксис

Процедура ОтключитьОбработчикОжидания() имеет следующий синтаксис:

ОтключитьОбработчикОжидания(ИмяПроцедуры)

А также альтернативный англоязычный синтаксис:

DetachIdleHandler(ProcName)

Параметры

Описание параметров процедуры ОтключитьОбработчикОжидания():

Имя параметра Тип Описание
ИмяПроцедуры Строка Имя процедуры, используемой в качестве обработчика ожидания.
Жирным шрифтом выделены обязательные параметры

Описание

Процедура ОтключитьОбработчикОжидания() отключает обработчик ожидания, подключенный ранее при помощи процедуры ПодключитьОбработчикОжидания().

Внимание! Если обработчик до этого подключен не был, система не сообщит об ошибке и не выполнит никаких действий

Доступность

Тонкий клиент, веб-клиент, мобильный клиент, толстый клиент, мобильное приложение(клиент).

Пример использования

Пример кода с использованием процедуры ОтключитьОбработчикОжидания():

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    //вызовем обработчик сразу после открытия формы (однократно)
    ПодключитьОбработчикОжидания("ОбработчикФормы", 0.1, Истина);
    
КонецПроцедуры

&НаКлиенте
Процедура КомандаОтключить(Команда)

    ОтключитьОбработчикОжидания("ОбработчикФормы");
    
КонецПроцедуры

&НаКлиенте
Процедура ОбработчикФормы()
    
    Сообщить(ТекущаяДата());    
    
КонецПроцедуры //ОбработчикФормы()

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *