0

Процедура ПодключитьОбработчикОжидания()

Подключает указанную процедуру в качестве обработчика ожидания

Синтаксис

Процедура ПодключитьОбработчикОжидания() имеет следующий синтаксис:

ПодключитьОбработчикОжидания(ИмяПроцедуры, Интервал, [Однократно])

А также альтернативный англоязычный синтаксис:

AttachIdleHandler(ProcName, Latency, [OneTime])

Параметры

Описание параметров процедуры ПодключитьОбработчикОжидания():

Имя параметра Тип Описание
ИмяПроцедуры Строка Имя процедуры, подключаемой в качестве обработчика ожидания
Интервал Число Интервал времени в секундах с точностью до 1/10 секунды, через который будет осуществляться вызов процедуры (положительное число). Если интервал вызова меньше 1 секунды, то значение параметра Однократно должно быть равно Истина.
Однократно Булево Признак однократного выполнения обработчика ожидания. Истина — указанный обработчик ожидания будет выполнен один раз.
Жирным шрифтом выделены обязательные параметры

Описание

Процедура ПодключитьОбработчикОжидания() подключает указанную процедуру в качестве глобального обработчика ожидания или обработчика ожидания формы. Процедура должна располагаться в модуле приложения или глобальном общем модуле (обязательно с ключевым словом Экспорт), либо в модуле формы. Процедура не должна иметь формальных параметров. Если одно из этих требований не будет выполняться, будет вызвана ошибка времени исполнения «Недопустимое значение параметра номер 1«

Указанная процедура будет вызываться в «состоянии покоя» системы (когда программа не выполняет никаких действий) каждый раз по истечению указанного интервала времени. Может быть подключено произвольное количество обработчиков ожидания.

Внимание! Во время временной блокировки, вызванной методом ЗаблокироватьРаботуПользователя() или соответствующей командой «Временная блокировка», обработчики ожидания не выполняются.
Внимание!! Если обработчик ожидания подключен из формы, его вызов будет продолжаться, пока форма не будет закрыта или пока указанный обработчик не будет отключен методом ОтключитьОбработчикОжидания().

Доступность

Тонкий клиент, веб-клиент, мобильный клиент, толстый клиент, мобильное приложение(клиент).

Пример использования

Пример кода с использованием процедуры ПодключитьОбработчикОжидания():

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    //вызовем обработчик сразу после открытия формы (однократно)
    ПодключитьОбработчикОжидания("ОбработчикФормы", 0.1, Истина);
    
КонецПроцедуры

&НаКлиенте
Процедура КомандаПодключить(Команда)

    ПодключитьОбработчикОжидания("ОбработчикФормы", 3);
    
КонецПроцедуры

&НаКлиенте
Процедура КомандаОтключить(Команда)

    ОтключитьОбработчикОжидания("ОбработчикФормы");
    
КонецПроцедуры

&НаКлиенте
Процедура ОбработчикФормы()
    
    Сообщить(ТекущаяДата());    
    
КонецПроцедуры //ОбработчикФормы()

Читайте также:

  1. Как сделать паузу в коде?

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *