0

Ошибка «Интерактивный выбор режима проведения документа не поддерживается»

Данная ошибка происходит при сочетании следующих настроек:

  • Для объекта метаданных разрешено оперативное проведение;
  • Ранее проведенный документ перепроводится текущим днем;
  • Для управляемой формы установлено свойство «Использовать режим проведения» (ИспользоватьРежимПроведения) в значение «Запрашивать»;

В тех же самых условиях для обычной формы платформа выдала бы запрос о режиме проведения документа, но режиме управляемого приложения что-то пошло не так. На сайте ИТС сказано, что оперативно проводимый документ при проведении текущим днем ВСЕГДА ПРОВОДИТСЯ В ОПЕРАТИВНОМ РЕЖИМЕ. Хотя, чисто логически, документ не должен бы сдвигаться по временной оси:

Как же решить эту проблему!?

Можно попробовать установить свойство управляемой формы «Использовать режим проведения» в значение «Автоматически» и устанавливать неоперативный режим проведения перед записью документа, например в процедуре ПередЗаписьюНаСервере():

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
	
	ПараметрыЗаписи.Вставить("РежимПроведения", РежимПроведенияДокумента.Неоперативный);
	
КонецПроцедуры

Однако это не работает и документ упорно продолжает проводиться оперативно, раз за разом перенося дату документа на текущее время.

Что же делать!? Спокойно! Выход есть)

Нужно программно изменять свойство управляемой формы «Использовать режим проведения» на значение «Неоперативный». Но делать это нужно обязательно на стороне сервера (иначе Вы получите ошибку «Поле объекта недоступно для записи (ИспользоватьРежимПроведения)»), например в процедуре ПриСозданииНаСервере():

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	Если Объект.Проведен = Истина Тогда
		//исключаем бесконечное оперативное проведение
		ЭтаФорма.ИспользоватьРежимПроведения = ИспользованиеРежимаПроведения.Неоперативный;	
	КонецЕсли;
	
КонецПроцедуры

Однако, и у этого способа есть недостаток: чтобы перепровести документ оперативно (текущим временем), его нужно будет снять с проведения, а затем провести из формы.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *