2

СписокЗначений
Метод Удалить()

Удаляет элемент из списка значений.

Синтаксис

Метод Удалить() имеет следующий синтаксис:

Удалить(Элемент)

А также альтернативный англоязычный синтаксис:

Delete(Элемент)

Параметры

Описание параметров метода Удалить():

Имя параметра* Тип Описание
Элемент Число Индекс удаляемого элемента
ЭлементСпискаЗначений Удаляемый элемент.
*Жирным шрифтом выделены обязательные параметры

Описание

Метод Удалить() удаляет элемент из списка значений. Можно удалить элемент по его индексу, либо указать конкретный элемент списка значений.

Доступность

Тонкий клиент, веб-клиент, мобильный клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).

Пример использования

Пример кода с использованием метода Удалить():

сз = Новый СписокЗначений; 
сз.Добавить(1); 
сз.Добавить(2);

//найти элемент и удалить
найдЭлт = сз.НайтиПоЗначению(1);
Если НЕ найдЭлт = Неопределено Тогда
    сз.Удалить(найдЭлт);
КонецЕсли;

//удалить первые 3
Для Инд = 0 По 3 Цикл
    Если сз.Количество() = 0 Тогда
        Прервать;
    КонецЕсли;
    сз.Удалить(0);
КонецЦикла;

//удалить все
Пока сз.Количество() > 0 Цикл    
    сз.Удалить(0);
КонецЦикла;       
//но лучше сделать так:
сз.Очистить();

Поделиться страницей в соц.сетях

2 мысли на “СписокЗначений
Метод Удалить()

  1. Для Инд = 1 По список.Количество() Цикл
    Если Инд> список.Количество() Тогда
    Прервать
    Конецесли;
    Если Список[Инд-1].Значение= «условие» Тогда
    элт = Список[Инд -1];
    Список.Удалить(элт);
    Инд=Инд-1;
    КонецЕсли;

    КонецЦикла;

    1. Дмитрий, я понял, что Вы хотите сказать)) Поправил тексты примеров. В одном из релизов платформы удаление (на удивление) удаляло все значения в прямом направлении, хотя обычно (еще со времен 1с 7.7) работало только удаление в обратном порядке…

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *