0

СписокЗначений
Метод ОтметитьЭлементы()

Открывает диалог для интерактивной пометки элементов списка.

Синтаксис

Метод ОтметитьЭлементы() имеет следующий синтаксис:

булево ОтметитьЭлементы([Заголовок=""])

А также альтернативный англоязычный синтаксис:

bool CheckItems([Title=""])

Параметры

Описание параметров метода ОтметитьЭлементы():

Имя параметра Тип Описание
Заголовок (необязательный) Строка Заголовок окна диалога. Если параметр не указан, то используется стандартный заголовок. Значение по умолчанию: Пустая строка.
Жирным шрифтом выделены обязательные параметры

Возвращаемое значение

Булево
Описание возвращаемых значений:

Истина — пользователь нажал в диалоге кнопку «ОК»
Ложь — пользователь отказался от выбора

Описание

Метод ОтметитьЭлементы() открывает диалог для интерактивной пометки пользователем элементов списка.

Доступность

Тонкий клиент, веб-клиент, мобильный клиент, толстый клиент, мобильное приложение(клиент).

Пример использования

Пример кода с использованием метода ОтметитьЭлементы():

сз = Новый СписокЗначений;
сз.Добавить(1);
сз.Добавить(2);
сз.Добавить(3);
//отобразим пользователю диалог для пометки значений
Если сз.ОтметитьЭлементы() = Истина Тогда
	Для Каждого Элт Из сз Цикл
		Если Элт.Пометка = Истина Тогда
			Сообщить(Элт.Значение);
		КонецЕсли;
	КонецЦикла;
КонецЕсли;

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *