0

Справочник
Метод ИспользоватьРодителя()

Задает родителя для иерархического справочника

Синтаксис

Метод ИспользоватьРодителя() имеет следующий синтаксис:

справочник ИспользоватьРодителя([Родитель], [МожноИзменять = 1])

А также альтернативный англоязычный синтаксис:

reference UseParent([Parent], [ChangeMode = 1])

Параметры

Описание параметров метода ИспользоватьРодителя():

Имя параметра Тип Описание
Родитель Справочник значение группы справочника, используемой в качестве родителя
МожноИзменять Число задает возможность интерактивной смены родителя в форме выбора. Возможные значения:

1 — пользователь может изменить родителя интерактивно (значение по умолчанию)
0 — пользователь не может изменить установленного родителя
Внимание! данный параметр имеет смысл только при интерактивном выборе в форме выбора
Жирным шрифтом выделены обязательные параметры

Возвращаемое значение

Справочник — ссылка на текущую группу справочника

Описание

Метод ИспользоватьРодителя() задает родителя для иерархического справочника. Метод возвращает значение текущей группы-родителя справочника.

Для объектов типа Справочник, созданных функцией СоздатьОбъект(), используется для:

  • организации выборки элементов справочника, находящихся в определенной группе справочника. Метод следует использовать до вызова методов ВыбратьЭлементы() и ВыбратьЭлементыПоРеквизиту(), формирующих выборку;
  • организации выбора элемента справочника, подчиненного определенной группе справочника, в форме выбора, открываемой программно. Метод следует использовать до вызова метода Выбрать(), генерирующего форму выбора. Доступно использование параметра МожноИзменять;
  • автоматической установки родителя новым элементам справочника. Метод следует использовать до вызова метода Новый() или НоваяГруппа(), создающих новый объект данного типа;

Для реквизитов типа Справочник, размещенных в диалогах и формах, устанавливает текущую группу родителя, в пределах которой будет осуществляться интерактивный выбор в форме выбора при нажатии пользователем кнопки выбора (…). Доступно использование параметра МожноИзменять.

Пример использования

Пример кода с использованием метода ИспользоватьРодителя():

//выборка по родителю
Справочник = СоздатьОбъект("Справочник.Контрагенты");
Справочник.ИспользоватьРодителя(ВыбКонтрагент);
Справочник.ВыбратьЭлементы();
Пока Справочник.ПолучитьЭлемент() = 1 Цикл
	Сообщить(Справочник.ПолноеНаименование());
КонецЦикла;
//Результат:
// ПОКУПАТЕЛИ/Азалия 
// ПОКУПАТЕЛИ/Бегония

//выбор в иерархическом справочнике программным путем
Справочник = СоздатьОбъект("Справочник.Контрагенты");
Справочник.ИспользоватьРодителя(ВыбКонтрагент);
Если Справочник.Выбрать("Укажите контрагента",) = 1 Тогда
	Сообщить(Справочник.ПолноеНаименование());
КонецЕсли;
            
//выбор в иерархическом справочнике интерактивным способом
ГруппаКонтрагентов = СоздатьОбъект("Справочник.Контрагенты");
Если ГруппаКонтрагентов.НайтиПоНаименованию("Поставщики") = 1 Тогда
	ВыбКонтрагент.ИспользоватьРодителя(ГруппаКонтрагентов);
КонецЕсли

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *