0

Справочник
Метод ВыбратьЭлементыПоРеквизиту()

Открывает выборку элементов справочника по значению реквизита

Синтаксис

Метод ВыбратьЭлементыПоРеквизиту() имеет следующий синтаксис:

число ВыбратьЭлементыПоРеквизиту(ИмяРеквизита, Значение, [РежимИерархии = 1], [РежимГрупп = 0])

А также альтернативный англоязычный синтаксис:

number SelectItemsByAttribute(Name, Value, [Mode = 1], [GroupMode = 0])

Параметры

Описание параметров метода ВыбратьЭлементыПоРеквизиту():

Имя параметра Тип Описание
ИмяРеквизита Строка имя реквизита выборки, как оно задано в конфигураторе
Значение Произвольный значение реквизита для выборки
РежимИерархии Число режим выборки в иерархическом справочнике

1 — выбирать с учетом иерархии (значение по умолчанию)
0 — выбирать без учета иерархии
РежимГрупп Число режим выборки групп и элементов

1 — выбирать только среди групп
0 — выбирать только среди элементов (значение по умолчанию)
Жирным шрифтом выделены обязательные параметры

Возвращаемое значение

Число

1 — выборка открыта и в ней присутствует хотя бы один элемент
0 — не удалось открыть выборку (нет ни одного элемента)

Описание

Метод ВыбратьЭлементыПоРеквизиту() открывает выборку элементов справочника по значению реквизита. Метод можно использовать только для объектов, созданных функцией СоздатьОбъект().

Последующий перебор выбранных элементов осуществляется методом ПолучитьЭлемент().

Внимание! Метод можно использовать только для реквизитов с установленным признаком Сортировка

Пример использования

Пример кода с использованием метода ВыбратьЭлементыПоРеквизиту():

//поиск среди групп и элементов
Справочник = СоздатьОбъект("Справочник.Контрагенты");
Если Справочник.ВыбратьЭлементыПоРеквизиту("ИНН", ИНН) = 1 Тогда
	Пока Справочник.ПолучитьЭлемент() = 1 Цикл
		Сообщить(Справочник.ПолноеНаименование());
	КонецЦикла;
КонецЕсли;
                            
//поиск только по элементам
Справочник = СоздатьОбъект("Справочник.Контрагенты");
Если Справочник.ВыбратьЭлементыПоРеквизиту("ИНН", ИНН, 0, 0) = 1 Тогда
	Пока Справочник.ПолучитьЭлемент() = 1 Цикл
		Сообщить(Справочник.ПолноеНаименование());
	КонецЦикла;
КонецЕсли;

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *