0

Справочник
Метод ВключатьПодчиненные()

Управляет включением подчиненных элементов в выборку

Синтаксис

Метод ВключатьПодчиненные() имеет следующий синтаксис:

число ВключатьПодчиненные([Значение = 1])

А также альтернативный англоязычный синтаксис:

number IncludeChildren([Value = 1])

Параметры

Описание параметров метода ИспользоватьРодителя():

Имя параметра Тип Описание
Значение Число задает режим выборки подчиненных элементов. Возможные значения:

1 — включать в выборку подчиненные элементы (значение по умолчанию)
0 — не включать подчиенные элементы
Жирным шрифтом выделены обязательные параметры

Возвращаемое значение

Число
Текущее числовое значение режима выборки подчиненных:

1 — подчиненные элементы включаются в выборку
0 — подчиненные элементы не включаются

Описание

Метод ВключатьПодчиненные() управляет включением подчиненных элементов в выборку. По-умолчанию подчиненные элементы всегда включаются в выборку, поэтому использовать данный метод есть смысл только в тех случаях, когда нужно отключить такую возможность.

Метод доступен только для объектов, созданных функцией СоздатьОбъект(). Его следует использовать до вызова методов ВыбратьЭлементы() и ВыбратьЭлементыПоРеквизиту(), фактически открывающих выборку.

Пример использования

Пример кода с использованием метода ВключатьПодчиненные():

//выборка только корневых групп
Справочник = СоздатьОбъект("Справочник.Контрагенты");
Справочник.ВключатьПодчиненные(0);
Справочник.ВыбратьЭлементы();
Пока Справочник.ПолучитьЭлемент() = 1 Цикл
	Сообщить(Справочник.ПолноеНаименование());
КонецЦикла;
//Результат:
// ПОКУПАТЕЛИ 
// ПОСТАВЩИКИ

//возвращаем выбор подчиненных
Справочник.ВключатьПодчиненные(1);
ГруппаКонтрагентов = СоздатьОбъект("Справочник.Контрагенты");
Если ГруппаКонтрагентов.НайтиПоНаименованию("Покупатели") = 1 Тогда
	Справочник.ИспользоватьРодителя(ГруппаКонтрагентов);
КонецЕсли;
Справочник.ВыбратьЭлементы();
Пока Справочник.ПолучитьЭлемент() = 1 Цикл
	Сообщить(Справочник.ПолноеНаименование());
КонецЦикла;
//Результат:
// ПОКУПАТЕЛИ/Азалия
// ПОКУПАТЕЛИ/Бегония

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *