0

Процедура ЗафиксироватьТранзакцию()

Процедура используется для завершения транзакции, открытой явным образом

Синтаксис

Процедура ЗафиксироватьТранзакцию() имеет следующий синтаксис:

ЗафиксироватьТранзакцию()

А также альтернативный англоязычный синтаксис:

CommitTransaction()

Параметры

Процедура ЗафиксироватьТранзакцию() не имеет формальных параметров.

Описание

Процедура ЗафиксироватьТранзакцию() закрывает (фиксирует) транзакцию, открытую явным образом. Все изменения, внесенные в базу данных до этого оператора, будут гарантированно сохранены в базе.

Данную процедуру не следует использовать в предопределенных процедурах ОбработкаПроведения() и ОбработкаУдаленияПроведения() модуля документа, т.к. они неявно выполняются платформой в транзакции. Подробнее о транзакциях рассказано в главе «Транзакции в 1С 7.7».

Помните, что в транзакциях, а также в обработчиках проведения документов, запрещается использовать интерактивные процедуры и функции, вроде: Вопрос(), Предупреждение() и другие;

Пример использования

Пример кода с использованием процедуры ЗафиксироватьТранзакцию()

НачатьТранзакцию();
	
    Спр = СоздатьОбъект("Справочник.ЦеновыеГруппы");
    
    //установим наценку на холодильники
    Если Спр.НайтиПоНаименованию("Холодильники") = 1 Тогда
        Спр.Наценка = 25;
        Спр.Записать();
    КонецЕсли;
    
    //установим наценку на посудомоечные машины
    Если Спр.НайтиПоНаименованию("Посудомоечные машины") = 1 Тогда
        Спр.Наценка = 35;
        Спр.Записать();
    КонецЕсли;
    
    //установим наценку на чайники
    Если Спр.НайтиПоНаименованию("Чайники") = 1 Тогда
        Спр.Наценка = 40;
        Спр.Записать();
    КонецЕсли;

ЗафиксироватьТранзакцию();

Читайте также:

Процедура НачатьТранзакцию();

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *