0

Процедура НачатьТранзакцию()

Процедура используется для явного начала транзакции

Синтаксис

Процедура НачатьТранзакцию() имеет следующий синтаксис:

НачатьТранзакцию()

А также альтернативный англоязычный синтаксис:

BeginTransaction()

Параметры

Процедура НачатьТранзакцию() не имеет формальных параметров.

Описание

Процедура НачатьТранзакцию() открывает транзакцию явным образом. Все изменения, внесенные в базу данных после этого оператора, будут гарантированно либо полностью приняты, либо полностью отменены.

Данную процедуру не следует использовать в предопределенных процедурах ОбработкаПроведения() и ОбработкаУдаленияПроведения() модуля документа, т.к. они неявно выполняются платформой в транзакции. Подробнее о транзакциях рассказано в главе «Транзакции в 1С 7.7».

Помните, что в транзакциях, а также в обработчиках проведения документов, запрещается использовать интерактивные процедуры и функции, вроде: Вопрос(), Предупреждение() и другие;

Пример использования

Пример кода с использованием процедуры НачатьТранзакцию()

НачатьТранзакцию();
	
    Спр = СоздатьОбъект("Справочник.ЦеновыеГруппы");
    
    //установим наценку на холодильники
    Если Спр.НайтиПоНаименованию("Холодильники") = 1 Тогда
        Спр.Наценка = 25;
        Спр.Записать();
    КонецЕсли;
    
    //установим наценку на посудомоечные машины
    Если Спр.НайтиПоНаименованию("Посудомоечные машины") = 1 Тогда
        Спр.Наценка = 35;
        Спр.Записать();
    КонецЕсли;
    
    //установим наценку на чайники
    Если Спр.НайтиПоНаименованию("Чайники") = 1 Тогда
        Спр.Наценка = 40;
        Спр.Записать();
    КонецЕсли;

ЗафиксироватьТранзакцию();

Читайте также:

Процедура ЗафиксироватьТранзакцию();

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *