Для разработчика » Содержание справочника » Раздел 1. Введение во встроенный язык » 
1

Знакомство с программными модулями

Формат программного модуля

Неотъемлемой частью любой конфигурации является программный модуль. Программным он называется потому, что содержит в себе исходные тексты алгоритмов, написанных на встроенном языке, или, проще — код. Строительными элементами программного модуля являются операторы и комментарии.

Операторы – это конструкции языка, выполняющие определенные действия.

Комментарии – фрагменты текста, содержащие пояснительную информацию.

Иными словами, программный модуль представляет собой последовательность операторов встроенного языка и комментариев.

Для наглядности материала, излагаемого далее, я покажу как мог бы выглядеть модуль «Hello world!», реализованный на встроенном языке 1С:Предприятие версии 7.7:

//объявление переменной модуля
Перем СтрокаПриветствия;

Процедура HelloWorld()
	          
	//инициализация переменной модуля
	СтрокаПриветствия = "Hello World!";

	//вывод сообщения пользователю
	Сообщить(СтрокаПриветствия);
	
КонецПроцедуры

//вызов процедуры модуля
HelloWorld();

Операторы

Каждый оператор может располагаться на одной строке или занимать несколько идущих подряд строк модуля. Для обозначения конца оператора используется символ ; (точка с запятой). Он же используется для разделения операторов друг от друга. Обратите внимание, что признак конца строки не является окончанием оператора. Он лишь указывает на то, что оператор перешел на следующую строку. Справедливо и обратное утверждение: в одной строке могут располагаться несколько идущих подряд операторов, разделенных точкой с запятой.

Комментарии

В коде могут содержаться фрагменты произвольного текста, иначе называемые комментариями. В отличие от операторов, комментарии не являются исполняемым кодом, хотя и могут содержать его элементы. Они нужны для пояснения действий операторов программы. Комментарий может начинаться в любом месте строки текста программы с двух идущих подряд символов косой черты // и заканчивается символом конца строки:

//это односточный комментарий

Во встроенном языке отсутствует привычный для многих программистов многострочный комментарий. Вместо него используются несколько, идущих подряд, однострочных:

//только так
//можно реализовать
//многострочный комментарий
//на встроенном языке

Идентификаторы

Идентификаторы используются в качестве символьных имен переменных и исполняемых операторов. Идентификаторы должны быть уникальными в своем окружении, не должны повторять зарезервированные слова встроенного языка, а также идентификаторы других исполняемых операторов.

Идентификатором может быть любая последовательность букв, цифр и знаков подчеркивания, начинающаяся с буквы или знака подчеркивания. Вновь создаваемые имена не должны совпадать с зарезервированными словами языка, а также с именами других переменных и исполняемых операторов.

Распознавание идентификаторов во встроенном языке является регистро-независимым. Т.о. имена переменных имяпеременной и ИмяПеременной будут эквивалентны, а попытка повторного объявления вызовет синтаксическую ошибку «Переменная с указанным именем уже определена!»

Зарезервированные слова

Во встроенном языке на платформе 1С:Предприятие 7.7 есть перечень ключевых слов, которые зарезервированы и не могут  выступать в роли идентификаторов переменных, и определяемых разработчиком процедур и функций. Перечень зарезервированных слов, а также их англоязычных синонимов, приведен в таблице:

Возврат (Return) КонецПроцедуры (EndProcedure) Продолжить (Continue)
Дата (Date) КонецФункции (EndFunction) Процедура (Procedure)
Для (For) КонецЦикла (EndDo) Разм (Dim)
Если (If) Контекст (Context) Строка (String)
Знач (Val) Не (Not) Тогда (Then)
И (And) Перейти (Goto) Формат (Format)
Или (Or) Перем (Var) Функция (Function)
Иначе (Else) По (To) Цикл (Do)
ИначеЕсли (ElseIf) Пока (While) Число (Number)
КонецЕсли (EndIf) Прервать (Break)

Алфавит встроенного языка

Как любой другой язык программирования, встроенный язык на платформе 1С:Предприятие  версии 7.7 имеет свой алфавит – набор допустимых символов, из которых создаются идентификаторы переменных, процедур и функций, составляются выражения и комментарии.

Алфавит встроенного языка включает буквы, цифры и специальные символы. Ниже приведен полный набор допустимых символов языка:

А-Яа-яA-Za-z Буквы
0-9 Цифры
| ( ) [ ]  . , ; _ « » ‘ ’ Ограничители и разделители
= Оператор присваивания
+ — Унарные арифметические операции
+ — * / % Бинарные арифметические операции
= <> > >= <= < Операции сравнения
? ~ : Операторы передачи управления
// Комментарий
1С Интерес
Нетология
1С Интерес
1С Интерес

Комментарии

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *